Adsense not showing | WordPress.org

Good day
Hope all is well.
I am building the site but I am not a developer.

Current situation:
My AdSense account has been approved and linked to the website.
I have Sitekit installed and it indicates connected and that the code has been inserted.
It has been weeks now and no ads have been displayed. I started troubleshooting and have been trying to get it to work for a week and a bit. No joy

I have tried reactivating and even reinstalling Sitekit.
I tried manually inserting ads via HTML and auto ads. With and without an ads plugin (Ads inserter).
I tried manually inserting the auto ads code with a code inserter plugin(WPcode) in my theme editor and just placing an HTML block with the code in my header template of Elementor pro.
I have disabled my ads blocker and even disable my entire anti-virus for short periods. For my computer and website. I place Wordfence in learning mode while installing and activating Sitekit.
I disabled my caching plugin(Litespeed) for a while but reactivated it and now disable all Java optimization i.e. not deferring or delaying, no minification, and no combining internal or external.
All my plugins are up to date and my PHP is on the higher level 7.4 and WordPress is on 6.0.2. Despite this problem persisting for a few weeks already.

Up to now, I still have not had a single ads display on my website. Except for one place.
While I am in editing my created pages on Elementor Pro builder ads display at the bottom of the content section. I mean like reals ads(FX Trading ads) not just the space holders.

Any assistance will be greatly appreciated
Thanks in advance.

The page I need help with: [log in to see the link]

 

This site will teach you how to build a WordPress website for beginners. We will cover everything from installing WordPress to adding pages, posts, and images to your site. You will learn how to customize your site with themes and plugins, as well as how to market your site online.

Your Advertisement Here