Consent modal immediately minimizes on page load

Plugin Support
daniub

(@daniub)

Hi,

can you please provide the URL of the website where we can see the issue?

Sure. I’ve reactivated the plugin, so you can check if anything is out of place.

https://kantoorplanten.com/

Plugin Support
daniub

(@daniub)

Hi,

we can confirm that the banner is visible correctly on the frontend: https://prnt.sc/ntKSL73XuNkw

How we can reproduce the issue?

Some additional information:

This behaviour occurs in the Chrome Browser on MacOS 14.5.
I just chekd if there was an update for Chrome and there was.
After updating, the issue did not resolve.
Chrome version: 126.0.6478.115 (Official Build) (x86_64)

In Firefox everyting works like expected after turning off ‘Respect Do Not Track and Global Privacy Control’. Which is pretty obvious.

Safari works fine as well.

In Brave, both the stylesheet and javascript of the plugin are blocked.
Error message: net::ERR_BLOCKED_BY_CLIENT
All other script and style files load without problems.
Brave version: Version Chromium: 126.0.6478.114 (Official Build) (x86_64)

So it looks like there are issues with the laterst Chromium versions (on MacOS).

  • This reply was modified 5 hours, 35 minutes ago by Arno Kools.
  • This reply was modified 5 hours, 33 minutes ago by Arno Kools.

Plugin Support
daniub

(@daniub)

Hi,

we have investigated and the banner is visible also on mac / google chrome with the same version, so we can safely exclude bugs on Chrome versions: https://prnt.sc/HL9-GBWYXjeg

Furthermore the error message looks like a local issue in your network: please try to delete your cache and check eventually your network settings in order to exclude local issues.

We also encourage you to have a look at this article: https://10web.io/blog/net-err_blocked_by_client-error/

I’m glad you’re not experiencing the same issue.

Just to be sure:
Does the modal appear automatically when loading the page?

At my computer, the modal does briefly appear for a few milliseconds before disappearing.
After clicking the ‘manage consent’ tab, the modal is correctly displayed and shows like in your screenshot.
But it’ does not on load.’s not clearly visible on load. And let be honest. Nobody is going to look for a somewhat hidden settings panel to turn on cookies.

Plugin Support
daniub

(@daniub)

Hi,

we confirm that the modal appears automatically on page loading.

Hope this helps!

Ok, thanks for confirming.
As long as these issues only occur on my development machine then it’s fine with me.

 

This site will teach you how to build a WordPress website for beginners. We will cover everything from installing WordPress to adding pages, posts, and images to your site. You will learn how to customize your site with themes and plugins, as well as how to market your site online.

Buy WordPress Transfer