Navigationslinks funktionieren nicht | ProjectDMC.org Deutsch

Hast du mal unter Einstelungen/Permalinks die Einstellungen neu gespeichert?

Ja, das habe ich gemacht – ohne Erfolg

Bei T-Home (T-Online) funktionieren Permalinks nur mit einer zusätzlichen Einstellung. vgl. T-Online & WordPress

Vielen Dank für deine Hilfe, aber leider funktioniert es nicht. Ich bin genauso vorgegangen wie es in deiner Anleitung steht, ledigleich in der .htaccess Datei habe ich den Verweis auf das wordpress-Verzeichnis entfernt:

# BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

und zwar deshalb, weil meine WordPress-Installation direkt im Verzeichnis „public_html“ liegt, also in keinem Unterverzeichnis.

Viele Grüße

Hast du denn eine httpd.conf erstellt?

Ja klar und im Verzeichnis „etc“ auf gleicher Ebene wie dem Verzeichnis „public_html“ abgelegt.

Hier die httpd.conf

<Directory /home/www/public_html>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </Directory>

Bei T-Online habe ich den Eindruck, dass die Webhosting mehr so als Hobby betreiben. 😉

Frag mal beim Support nach, wieso das nicht geht.
Oder zu einem „gescheiten“ Webhoster wechseln.
Oder die Website ohne „Pretty Permalinks“ (mit Permalink-Einstellung „einfach“) nutzen. Ist dann nur nicht so gut für SEO.

Telekom ist ne Katastrophe. Leider ist mein Kunde bei der Telekom, was ich da in dem Zusammenhang die letzten Tage alles erlebte:
– Probleme mit dem Login (seit Tagen), es wird jedesmal beim Login ein Bestätigungslink angefordert der allerdings an die Mailadresse meines Kunden geht. Kann man eigentlich umstellen, funktioniert aber trotz Anfruf beim Support bis jetzt nicht.
– Der ursprüngliche Vertrag musste „upgedatet“ werden, damit WordPress installiert werden kann, dabei wurde von der Telekom versehentlich der Vertragsbeginn auf 1.5.2023 gelegt (ist leider erst spät aufgefallen)
– Und jetzt noch diese Probleme

Ich hoste meine Seiten ansonsten fast nur bei „all-inkl.com“ bin super zufrieden was für mich bedeutet es flutscht und erfordert keinen unnötigen Aufwand. Ansonsten „Strato“ geht auch und „Domainfactory“ (bei denen gibt es jedoch auch mal Probleme).

Viele Grüße

Wir vermeiden hier eigentlich aus Gründen der Neutralität, Webhoster zu beurteilen. Webhosting ist hier außerdem off topic.

Für solche Fälle haben die Core-Developer die Einstellungsmöglichkeit einfacher Permalinks vorgesehen und damit sollte die Website funktionieren. Wenn der Kunde beratungsresistent ist, lässt sich das vermutlich nicht anders lösen.

Sorry für meinen Ausdruck des Ärgers. Ihr habt ja recht – auf solch einer Plattform ist Neutralität richtig.

So, jetzt funktioniert alles wieder, aber warum weiß ich nicht. Ein Telekom-Techniker hat sich des Problems angenommen und irgendwas eingebaut (auf jeden Fall nichts was auf den Hilfeseiten der Telekom zum Thema „Permalinks“ zu finden ist). Nach seiner Aussage ist das Problem bekannt, leider wird auf den Hilfeseiten nichts dazu angeboten (oder kann nicht angeboten werden).

Schön dass dein Problem gelöst werden konnte. Ich setze den Thread dann einmal für dich auf „gelöst“.

Bitte denke nächstes Mal selbst daran. Begründung

 

This site will teach you how to build a WordPress website for beginners. We will cover everything from installing WordPress to adding pages, posts, and images to your site. You will learn how to customize your site with themes and plugins, as well as how to market your site online.

Buy WordPress Transfer