Page Editor Issues | WordPress.org

Not 100% sure if this issue is Beaver Builder related, but from my limited testing (switching themes, disabling plugins, clearing cache, etc, it seems like it might be).

So I’ve taken on the task of helping a friend with their website, and the more I dig into it, the more oddities and issues I’m finding with it. Luckily, it’s just a single page site, but I’ve encountered an issue that I haven’t ever experienced before which is that the published page is very different from what pops up on screen after I click the “Edit Page” link. If you look at the images I’ve posted below, you’ll see what I’m talking about. What’s even more odd is that if I click preview of publish, I see what’s on the second screen (on the editing page), which is a complete mess. If I go to the admin panel go click directly on the Homepage link, I also see the same jumbled mess, not what’s actually on the published homepage. No clue why this is happening.

I’ve cleared both the server side cache and browser cache, used different browsers, etc. but the issue persists. I’ve also deactivated all plugins, but that made no difference.

The site uses Beaver Builder Pro (2.4.2.5), Beaver Themer (1.3.1) and a BB Child theme (1.7.9). The site owner’s subscription has expired, so updates have not happened in a while on the builder, the themer or the theme itself.

Screen shots below for reference.

This is what the published homepage looks like.
This is what the backend looks like if you click Edit Page or select it for editing from the WP Admin dashboard.

The page I need help with: [log in to see the link]

 

This site will teach you how to build a WordPress website for beginners. We will cover everything from installing WordPress to adding pages, posts, and images to your site. You will learn how to customize your site with themes and plugins, as well as how to market your site online.

Buy WordPress Transfer