Stack Trace Errors | WordPress.org

[ad_1]

Hi guys,

I know you prefer to answer queries via your own forum but it’s a nightmare to get into – I just tried to reset my password following adding my username, and the email is floating around cyberspace somewhere.

So:

I’ve just been in touch with the guys at Relevanssi, stating that a numerical search crashes the website.

The Relevanssi guy said to check the error logs to find out why it crashed, or he wouldn’t be able to help.

What I DID find in my error logs was this:

Stack trace:
#0 /home/midland6/public_html/wp-content/plugins/wpforo.bak/wpforo.php(289): wpforo\wpforo->init_base_classes()
#1 /home/midland6/public_html/wp-includes/class-wp-hook.php(307): wpforo\wpforo->wpforo\{closure}('')
#2 /home/midland6/public_html/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters('', Array)
#3 /home/midland6/public_html/wp-includes/plugin.php(476): WP_Hook->do_action(Array)
#4 /home/midland6/public_html/wp-settings.php(576): do_action('after_setup_the...')
#5 /home/midland6/public_html/wp-config.php(125): require_once('/home/midland6/...')
#6 /home/midland6/public_html/wp-load.php(50): require_once('/home/midland6/...')
#7 /home/midland6/public_html/wp-blog-header.php(13): require_once('/home/midland6/...')
#8 /home/midland6/public_html/index.php(17): require('/home/midland6/...')
#9 {main}
  thrown in /home/midland6/public_html/wp-content/plugins/wpforo.bak/wpforo.php on line 242
[22-Sep-2022 10:59:43 UTC] PHP Fatal error:  Uncaught Error: Class 'wpforo\classes\Settings' not found in /home/midland6/public_html/wp-content/plugins/wpforo.bak/wpforo.php:242
Stack trace:
#0 /home/midland6/public_html/wp-content/plugins/wpforo.bak/wpforo.php(289): wpforo\wpforo->init_base_classes()
#1 /home/midland6/public_html/wp-includes/class-wp-hook.php(307): wpforo\wpforo->wpforo\{closure}('')
#2 /home/midland6/public_html/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters('', Array)
#3 /home/midland6/public_html/wp-includes/plugin.php(476): WP_Hook->do_action(Array)
#4 /home/midland6/public_html/wp-settings.php(576): do_action('after_setup_the...')
#5 /home/midland6/public_html/wp-config.php(125): require_once('/home/midland6/...')
#6 /home/midland6/public_html/wp-load.php(50): require_once('/home/midland6/...')
#7 /home/midland6/public_html/wp-blog-header.php(13): require_once('/home/midland6/...')
#8 /home/midland6/public_html/index.php(17): require('/home/midland6/...')
#9 {main}
  thrown in /home/midland6/public_html/wp-content/plugins/wpforo.bak/wpforo.php on line 242
[22-Sep-2022 11:00:03 UTC] PHP Fatal error:  Uncaught Error: Class 'wpforo\classes\Settings' not found in /home/midland6/public_html/wp-content/plugins/wpforo.bak/wpforo.php:242
Stack trace:
#0 /home/midland6/public_html/wp-content/plugins/wpforo.bak/wpforo.php(289): wpforo\wpforo->init_base_classes()
#1 /home/midland6/public_html/wp-includes/class-wp-hook.php(307): wpforo\wpforo->wpforo\{closure}('')
#2 /home/midland6/public_html/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters('', Array)
#3 /home/midland6/public_html/wp-includes/plugin.php(476): WP_Hook->do_action(Array)
#4 /home/midland6/public_html/wp-settings.php(576): do_action('after_setup_the...')
#5 /home/midland6/public_html/wp-config.php(125): require_once('/home/midland6/...')
#6 /home/midland6/public_html/wp-load.php(50): require_once('/home/midland6/...')
#7 /home/midland6/public_html/wp-cron.php(44): require_once('/home/midland6/...')
#8 {main}
  thrown in /home/midland6/public_html/wp-content/plugins/wpforo.bak/wpforo.php on line 242

So I deactivated WPForo and all went back to normal.

A fix is needed, please?

 

This site will teach you how to build a WordPress website for beginners. We will cover everything from installing WordPress to adding pages, posts, and images to your site. You will learn how to customize your site with themes and plugins, as well as how to market your site online.

Buy WordPress Transfer