Specific post keep disappearing | WordPress.org

(I can’t include a link because the post keeps disappearing.)

Three times now I’ve had to repost a specific post and every time, the next day, it’s gone! When I look into my staging site, which is not public, it’s always there.

For some reason WordPress is deleting that post and only that post. Or someone is hacking my website to delete that post and only that post!

There are security measures on my site that are supposed to stop that kind of activity, but they don’t seem to be working. They are:

  • Backend access restricted by IP in .htaccess, cloud firewall, UFW, and plugin iQ Block Country.
  • Manual captcha for all visitors to the backend.
  • OTP 2FA required to login to wp-admin.

I hope this is the correct place to post this as I’m now perplexed.

I recently did a malware scan and couldn’t find anything and I’ve reinstalled WordPress 6.0.2. I also installed the plugin WP Control and couldn’t find any cron jobs that might be deleting the post.

Again, it’s one specific post and no others!

Can someone help please?
Thank you.

  • This topic was modified 1 day, 1 hour ago by laughingseeds.
  • This topic was modified 1 day, 1 hour ago by laughingseeds. Reason: Grammar errors

 

This site will teach you how to build a WordPress website for beginners. We will cover everything from installing WordPress to adding pages, posts, and images to your site. You will learn how to customize your site with themes and plugins, as well as how to market your site online.

Your Advertisement Here