Error Messages after server database upgrade

After server database upgrade from Mariah 10.0 to 10.3, WordPress 6.0.2 running Weaver Xtreme theme reports a lot of errors on plugins, which I subsequently deactivated. But the following plugins do not appear to be plugin-related.

Message appears everywhere at the top of the page, often multiple times:

Deprecated: Function wpdb::escape is deprecated since version 3.6.0! Use wpdb::prepare() or esc_sql() instead. in /home/ssnet/public_html/wp-includes/functions.php on line 5401

These messages appear when comment is posted:

Warning: Cannot modify header information – headers already sent by (output started at /home/ssnet/public_html/wp-includes/functions.php:5401) in /home/ssnet/public_html/wp-content/plugins/litespeed-cache/src/vary.cls.php on line 729

Warning: Cannot modify header information – headers already sent by (output started at /home/ssnet/public_html/wp-includes/functions.php:5401) in /home/ssnet/public_html/wp-includes/pluggable.php on line 1421

Warning: Cannot modify header information – headers already sent by (output started at /home/ssnet/public_html/wp-includes/functions.php:5401) in /home/ssnet/public_html/wp-includes/pluggable.php on line 1424

These appear at top of Admin page:

Warning: Cannot modify header information – headers already sent by (output started at /home/ssnet/public_html/wp-includes/functions.php:5401) in /home/ssnet/public_html/wp-admin/includes/misc.php on line 1381

Warning: Cannot modify header information – headers already sent by (output started at /home/ssnet/public_html/wp-includes/functions.php:5401) in /home/ssnet/public_html/wp-includes/functions.php on line 6878

Warning: Cannot modify header information – headers already sent by (output started at /home/ssnet/public_html/wp-includes/functions.php:5401) in /home/ssnet/public_html/wp-admin/admin-header.php on line 9

What is the best way to fix these errors?

(Since I noted a Litespeed-related error, I’m seeking help from their support forum on that particular error. Just wanted to give a complete list here.)

Operating System
CentOS v7.9.2009
Product
cPanel & WHM v106.0.7 (STANDARD)
Using LiteSpeed Web Server plugin on an Apache system.

WordPress 6.0.2 running Weaver Xtreme theme.

The page I need help with: [log in to see the link]

 

This site will teach you how to build a WordPress website for beginners. We will cover everything from installing WordPress to adding pages, posts, and images to your site. You will learn how to customize your site with themes and plugins, as well as how to market your site online.

Your Advertisement Here